What You Need to Know About the Heartbleed Bug

Posted on: April 17, 2014
Tags: Just ask jean

Making waves in the Internet security community is the discovery of the Heartbleed bug, a serious vulnerability that allows hackers to steal personal information that is normally protected by OpenSSL encryption. OpenSSL provides security for Web applications, email, instant messaging and some virtual private networks. According to Internet security services provider Netcraft, about half a million trusted websites are vulnerable to the bug. Click here for more...

Leave a Comment